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Johdanto

Voit luoda saavuettavia PDF-tiedostoja useissa ohjelmissa, mutta vain Acrobat Professional -ohjelmassa voit arvioida, korjata ja kehittää olemassa olevien PDF-tiedostojen saavutettavuutta.

Huomaa!
Tässä artikkelissa kerrotaan vanhempien Acrobat Professional -ohjelmien, ensisijaisesti Acrobat 7-9, saavutettavuusominaisuuksista. Tätä sivua ei päivitetä, kun uudet Acrobat-versiot julkaistaan. Tietoa nykyisistä Acrobat-versioista on sivulla Acrobat X. Tietoa yleisestä PDF-saavutettavuudesta ja Microsoft Word -asiakirjojen sekä muiden tiedostojen muuntamisesta PDF-muotoon löytyy aloitussivulta PDF-asiakirjat ja saavutettavuus.

Koodit-paneeli

Note
Acrobat 8 -versiosta lähtien Adobe on nimennyt valikot (tabs) "paneeleiksi" (panels). Jos käytät Acrobat 7:ä tai aikaisempaa versiota, voit korvata ohjeissa käytetyn sanan "panel" sanalla "valikko".

Koodit-paneelissa (Tags panel) Koodit-paneelissa (Tags Panel) voi tarkastella, järjestellä, nimetä uudelleen, muokata, poistaa ja luoda tunnisteita. Saat esille Tags panelin valitsemalla View > Navigation Panels > Tags. Koodi-ikkunaa on ehkä helpompi tarkastella, jos sen sijoittaa sivupalkkiin. Sijoita ikkuna valitsemalla  View > Navigation Panels > Dock all Panels tai raahaa Tags Panel sivupalkkiin. Jostain syystä sijoittaminen ei onnistu, kun raahaa kokonaisen ikkunan. Se on laitettava kohdalleen raahaamalla paneeli.

Kun <Tags> ja <Sect> ovat avoinna, pitäisi näkyviin tulla pitkä luettelo tunnisteita. Tunnistelistassa pääsee liikkumaan hiirellä ja nuolinäppäimillä. Samoin listaa voi laajentaa ja supistaa.



Monet tunnisteista ovat samanlaisia tai samoja kuin HTML-kielessä. Joitain näistä tutuista tunnisteista on kuvailtu alla olevassa taulukossa:

	Tunniste	Käyttö	Kuvailu/Huomiot
	<H1> to <H6>	Heading (Otsikko)	
	<P>	Paragraph (Kappale)	
	<L>	List (Luetelo)	Vastaava kuin <ul> tai <ol> HTML-kielessä
	<LI>	List Item (Lista-alkio)	Tulisi laatia sisäkkäisiksi kuten HTML-kielessä, mikä voi olla haastavaa.
	<Table><TH><TR><TD>	Table, Table Row, Table Header, Table Data (taulukko, taulukon rivi, otsikko, data)	
	<Figure>	Figure (kuvio)	Vastaava kuin <img> -tagi HTML-kielessä

Sisällön korostaminen

Ensitoimiksi Koodi-paneelissa kannattaa valita Options -valikosta Highlight Content (korosta sisätö). Kun tämä vaihtoehto on käytössä, tulisi valittua tunnistetta vastaavan tekstin, kuvan tai muun elementin näkyä korostettuna PDF-asiakirjassa.



Koodin löytäminen valinnasta

Samaan tapaan kuin tunnisteen valitseminen korostaa sisällön PDF-tiedostossa, voidaan valittua sisältöä vastaava tunniste saada korostetuksi.  Napsauta ensiksi Select Tool  (valintaosoitinta). Seuraavaksi valitse tekstiä, kuva tai taulukko. Lopuksi valitse Options -valikko ylhäältä Tags panelista ja sitten Find Tag From Selection. Näin saat korostetuksi tunnisteen tai tunnisteet, jotka vastaavat valitsemaasi sisältöä.

Muuta tunnisteita

Joskus tulee kohdalle PDF-tiedostoja, joissa on virheellisiä tunnisteita. Voit muokata tiedostoja napsauttamalla hiiren oikealla painikkeella tunnistetta, jota haluat muuttaa ja valitsemalla Properties sitten Tag -välilehden ja valitsemalla sopivan tyypin uudelle tunnisteelle alasvetovalikosta Type.



Esimerkiksi vaihtaaksesi tunnisteen <Normal> tunnisteeksi <H1> valitse  <Normal> -tagi, jonka haluat vaihtaa ja toimi seuraavasti: Valitse hiiren oikealla painikkeella tunniste ja valitse Properties ja  sittenHeading Level 1 Type-listalta.

 



Lisää tunnisteet merkkaamattomaan asiakirjaan

Jos Koodit-paneelissa ei näy tunnisteita, asiakirjasi on merkkaamaton ja sinun tarvitsee lisätä siihen tunnisteet. Lisätäksesi tunnisteen merkkaamattomaan asiakirjaan, valitse Advanced > Accessibility > Add Tags to Document. Toiminnan toteutuminen kestää joskus pitkään, ja lisäksi joitain tunnisteita joutuu yleensä muokkaamaan. Tämä on kuitenkin hyvä alku ja todennäköisesti nopeampaa kuin kaiken tekeminen käsin. Näin on varsinkin jos asiakirja sisältää taulukoita.

Lukemisjärjestyksen muutostyökalu

Huomaa
Tämä ominaisuus on käytettävissä vain Acrobat 7:ssä ja myöhemmissä versioissa.

TouchUp Reading Order (Lukemisjärjestyksen muutostyökalu) on uusi ja lupaava ominaisuus Acrobat 7:ssä ja sitä seuraavissa versioissa. Se on ensimmäinen todellinen mahdollisuus merkata PDF nopeasti. Vaikka TouchUp Reading Order voi nopeuttaa merkkaamista, se ei korvaa aikaisemmin mainittuja työkaluja.

TouchUp Reading Order -työkalun saa käyttöön valitsemalla Advanced > Accessibility > TouchUp Reading Order. Kun tämä toiminto on valittu, näkymä näytöllä muuttuu. Kaikki sisältö näkyy numeroiduissa laatikoissa. Jokainen laatikoista vastaa tunnistetta ja jokainen numero vastaa tunnisteen numeroa Order paneelissa. Samalla avautuu TouchUp Reading Order -ikkuna.



Huomaa

Jos TouchUp Reading Order (Lukemisjärjestys) on avoinna eikä laatikoita näy, on todennäköistä, että PDF-asiakirjaasi ei ole merkattu.

Käytettävissä on ryhmä painikkeita, joissa on useiden yleisten tunnisteiden nimet. Painikkeilla saa tunnisteet valituille tekstiosuuksille tai muille kohteille.

TouchUp Reading Order ei ole täydellinen. Tekstin valitseminen on hankalaa ja kaikille tunnisteille ei ole tukea. Tekstivastineen liittäminen kuviin on jonkin verran työlästä. Siitä huolimatta on helpompi käyttää PDF-tiedoston merkkaamiseen tätä ominaisuutta kuin muita menetelmiä.

Tunnisteiden lisääminen/muuttaminen

TouchUp Reading Order -työkalulla voi valita tekstiosuuden, kuvan, taulukon tai muun elementin kahdelle eri tavalla.

	Vedä kehys sivun osan ympärille ristikko-osoittimilla (LISÄÄ TÄHÄN KUVAKE), jotka ovat hiiren tavanomaisen osoittimen tilalle. Tarkalleen oikean alueen valitseminen voi olla vaikeaa, mutta helpompaa on piirtää alueelle hieman kookkaampi kehys. Kun olet saanut valinnan tehdyksi, voit liittää alueeseen jonkin tunnisteista napsauttamalla jotain painikkeista.
	Voit myös valita laatikon kaiken sisällön napsauttamalla numeroa vasemmassa ylänurkassa.

Kun olet valinnut tekstin, voit liittää tunnisteen napsauttamalla vastaavaa painiketta. Valittuasi painikkeen Acrobat laittaa valitun sisällön haluttuihin tunnisteisiin. Jos Koodit-paneeli on avoinna, voit seurata siitä näitä muutoksia.

Kun Muuta lukemisjärjestystä on käytössä, voit myös liittää kuville tekstivastineen. Napsauta kuvaa hiiren oikealla painikkeella ja valitse Edit Alternate Text (Muokkaa vaihtoehtoista tekstiä).

TouchUp Reading Order -valinnat	Painike	Adobe-tunniste	Lisätieto
	Text	<P>	
	Form Field	<Form>	
	Heading 1	<H1>	
	Heading 2	<H2>	
	Heading 3	<H3>	
	Figure	<Figure>	
	Figure/Caption	<Figure> <Caption>	Jos valitset kuvan ja läheisen tekstin, kuvat merkataan kuvaksi ja teksti sen tekstitykseksi.
	Table	<Table>, <TR>, <TH> ja <TD>	Acrobat pyrkii lisäämään rivit, sarakkeet ja otsikot. Joskus se onnistuu, mutta on myös paikallaan tarkistaa table inspectorilla.
	Cell	<TD>	Tunnistetta voidaan käyttää yhdistämään väärin jaettuja soluja.
	Formula	<Formula>	
	Background	none	Kutsutaan myös artefaktiksi, tunniste piilottaa kohteen ruudunlukijalta.

Järjestys-paneeli

Huomaa
Tämä ominaisuus on käytettävissä vain Acrobat 7 Professionalissa ja sitä myöhemmissä versioissa.

Vaikka PDF-asiakirjan lukemisjärjestys voidaan muuttaa vastaamaan visuaalista lukemisjärjestystä raahaamalla tunnisteita eri paikkoihin Tags -paneelissa, on helpompi menetelmä käytettävissä Acrobat 7:ssä ja uudemmissa versioissa. Avataksesi Order-paneelin, valitse View > Navigation Panels > Order tai valitse Show Order Panel TouchUp Reading Order -työkalusta.



Ensinäkemältä Järjestys-paneeli muistuttaa Koodit-paneelia, mutta niiden välillä on joitain eroavaisuuksia.

	Asiakirja on jaettu sivuihin.
	Jokainen elementti on numeroitu. Numerot alkavat alusta jokaisella sivulla.
	Elementtien kesken ei ole hierarkiaa, vaan kaikki sisältö on samalla tasolla.

Näiden eroavaisuuksien ansiosta Järjestys-paneelissa voi muuttaa tunnisteiden järjestystä merkittävästi helpommin.  Muuttaaksesi jonkin elementin paikkaa lukemisjärjestyksessä napsauta tunnistetta ja vedä se hiirellä lukemisjärjestyksen oikeaan kohtaan. Uusi lukemisjärjestys näkyy Koodit-paneelissa ja asiakirjan Reflow (Uudelleenjuoksutus) -tilassa.

Tekstivastine

Helpoimmin tekstivastineen saa lisätyksi TouchUp Reading Order -työkalulla. Kun kuvalla on image- (tai figure) tunniste, tekstivastine ilmestyy kuvan yhteyteen. Jos kuvalla ei ole tekstivastinetta, se ilmoitetaan tekstissä "Figure - No alternate text exists."



Lisätäksesi tekstivastineen tai muokataksesi sitä napsauta kuvaa hiiren oikealla painikkeella ja valitse Edit Alternate Text. Kirjoita tarkoituksenmukainen tekstivastine keskusteluikkunaan (tarkemmin tekstivastineesta Appropriate Use of Alternative Text).

Taulukon tarkistus

Huomaa!
Tämä ominaisuus on käytettävissä vain Acrobat 8:ssa ja sitä myöhemmissä versioissa.

Table Inspector -työkalulla saat helposti tarkistettua ja määriteltyä taulukon otsikoiden ulottuvuudet.

TouchUp Reading Order (Lukemisjärjestyksen muutos) -työkalun ollessa avattuna valitse taulukko ja siitä Table Inspector. Sitten voit valita taulukon solut, joiden tulee olla otsikoita. Napsauta valittua solua hiiren oikealla painikkeella ja valitse Table Cell Properties. Keskusteluikkuna avautuu.



Jos valitsemasi solu tai solut tulee merkata otsikoiksi <th>, valitse Header Cell ja lisää merkattavaksi alueeksi Row (rivi) tai Column (sarake). Kun olet valinnut vahvistuksesi OK, huomaat, että taulukon otsikkosolut on merkitty punaisella ja tietosolut harmaalla.



Artefaktit

Artifacts (Artefaktit) ovat sisällön osia, jotka ruudunlukuohjelma jättää huomiotta samaan tapaan kuin kuvan, jolla on HTML-koodissa tyhjä tekstivastine. Tärkeää tekstiä ei pidä merkitä artefaktiksi. Helpoin tapa liittää tai poistaa artefaktitunniste on käyttää TouchUp Reading Order -työkalua. Artefaktitunnisteen saat valitsemalla elementin ja napsauttamalla Background-painiketta.

Löytääksesi artefaktit mene Tags-ruutuun ja valitse Options Find. Näyttöön avautuu ikkuna, jossa on useita hakumahdollisuuksia. Artifact on valittu oletuksena, joten napauta Find. Jos artefakteja on, haku tunnistaa ne. Voit muuttaa ne toisenlaisiksi elementeiksi.

Muuttaaksesi tunnisteen artefaktiksi Tags-ruudussa napsauta sitä hiiren oikealla painikkeella ja valitse Change Tag to Artifact.

Muita työkaluja ja ominaisuuksia


Skannatun tekstin muuntaminen

Ennen kuin voit luoda merkatun PDF-tiedoston, sinun on varmistettava, että PDF sisältää kelvollista tekstiä. Jos näin ei ole, sinun tulee joko luoda PDF-tiedosto uudelleen (jos sinulla on käytettävissäsi alkuperäinen tiedosto) tai muuntaa sen sisältö kunnolliseksi tekstiksi.

Muuntaaksesi asiakirjan valitse oikeanpuoleisesta palstasta Tools > Recognize Text. Tekstin laatu riippuu lähdeasiakirjan laadusta. Muunnos on tavallisesti kohtuullisen hyvä, mutta voi olla tarpeen siistiä asiakirja. Tee se valitsemalla Recognize Text -alavalikosta Find All Suspects.

Saavutettavuuden pikatarkistus

Acrobat Professional -ohjelmassa on kaksi erilaista saavutettavuuden tarkistusta. Näistä saavutettavuuden pikatarkistus, Quick Check, kuulostaa paremmalle kuin onkaan. Quick Check kertoo lähinnä, onko tiedostossa tunnisteet vai ei. Pikatarkistus ei tunnista edes tekstivastineiden puuttumisen kaltaisia perusvirheitä. Käynnistääksesi Quick Check -tarkistuksen valitse Advanced > Accessibility > Quick Check.

Saavutettavuuden kokonaistarkistus

Pikatarkistuksen kehitelty versio (Advanced > Accessibility > Full Check) on monipuolisempi, mutta edelleen monin tavoin puutteellinen. Full Check kuitenkin tunnistaa tekstivastineiden puuttumisen ja antaa korjausvihjeitä joidenkin virheiden korjaamiseksi.

Tekstin uudelleen juoksuttaminen

Ruudunlukuohjelma lukee PDF-asiakirjaa tunnisteiden mukaisessa järjestyksessä samaan tapaan kuin HTML-asiakirjaa. Tunnisteiden järjestys ei välttämättä ole sama kuin visuaalinen lukemisjärjestys, mikä on todennäköistä varsinkin, jos tiedoston tekstissä on useita palstoja, palkkeja tai monimutkaisia sisäkkäisiä listoja. Reflow Tool (Uudelleenjuoksutus työkalu) näyttää asiakirjan lukemisjärjestyksen sellaisena kuin tunnisteet sen määräävät.

Valitse View > Zoom > Reflow (Näytä > Suurenna > Juoksuta uudelleen) tai Ctrl + 4. Jos asiakirjan sisältö ei näy oikeassa järjestyksessä Reflow-näkymässä, on tarpeen muuttaa tunnisteiden järjestystä.

Lue ääneen -toiminto

Read Out Loud (Lue ääneen) on Adobe Reader- ja Adobe Acrobat-ohjelmien puhesyntetisaattori. Sillä voi luettaa ääneen PDF-asiakirjan sisällön ja saada tuntumaa siitä, mitä ruudunluvun käyttäjä kokee. Lisätietoa saat Read Out Loud section in the WebAIM article on Adobe Reader -artikkelin ääneenlukemisen osuudesta.

Lähde: http://webaim.org/techniques/acrobat/acrobat7to9. Copyright © WebAIM
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